Skip to main content
CVE-2026-3528VulnerabilityPublished

CVE-2026-3528: Drupal Calculation Fields · "Cross-site Scripting"

Affects Drupal Calculation FieldsSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.0.4 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Drupal Calculation Fields to 1.0.4.

Affected software

ProductAffectedFixed in
DrupalCalculation FieldsAffected
  • <1.0.4
Fixed in
  • 1.0.4

AI-suggested

To mitigate CVE-2026-3528, organizations should immediately verify if their Drupal installations use the Calculation Fields module and identify the version in use. They should upgrade the module to version 1.0.4 or later as soon as it becomes available, as this version addresses the input sanitization issues. In the interim, applying web application firewall (WAF) rules to detect and block suspicious input patterns related to XSS can reduce risk. Developers should review and enhance input validation and output encoding practices within custom Drupal modules and themes, ensuring all user-supplied data is properly sanitized before rendering. Additionally, implementing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts. Regular security audits and monitoring for unusual user activity or error logs related to script injection attempts are recommended. Finally, educating site administrators and users about the risks of XSS and safe browsing practices can reduce exploitation likelihood.

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Calculation Fields allows Cross-Site Scripting (XSS).This issue affects Calculation Fields: from 0.0.0 before 1.0.4.

References

Community reviews

Loading reviews…