CVE-2026-3529: Drupal Google Analytics GA4 · "Cross-site Scripting"
Affects Drupal Google Analytics GA4Source CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.1.14 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade Drupal Google Analytics GA4 to 1.1.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalGoogle Analytics GA4 | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-3529, organizations should immediately plan to update the Drupal Google Analytics GA4 module to version 1.1.14 or later once it is released, as this will contain the official patch addressing the input sanitization issue. If you cannot patch yet, web administrators should implement strict input validation and output encoding on all user-supplied data that the module processes or displays. Employing Content Security Policy (CSP) headers can help reduce the impact of XSS by restricting the execution of unauthorized scripts. Web Application Firewalls (WAFs) should be configured to detect and block common XSS attack patterns targeting this module. Regularly auditing and scanning Drupal sites for XSS vulnerabilities using automated tools can help identify residual issues. Additionally, educating developers and administrators about secure coding practices and the importance of sanitizing inputs can prevent similar vulnerabilities. Monitoring web server logs and user reports for unusual script execution or redirection behavior is also recommended to detect potential exploitation attempts early.
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Google Analytics GA4 allows Cross-Site Scripting (XSS).This issue affects Google Analytics GA4: from 0.0.0 before 1.1.14.