Skip to main content
CVE-2026-3530VulnerabilityPublished Updated

CVE-2026-3530: Drupal OpenID Connect / OAuth client · Server-Side Request Forgery (SSRF)

Affects Drupal OpenID Connect / OAuth clientSource CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium : upgrade to 1.5.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Drupal OpenID Connect / OAuth client to 1.5.0.

Affected software

ProductAffectedFixed in
DrupalOpenID Connect / OAuth clientAffected
  • <1.5.0
Fixed in
  • 1.5.0

AI-suggested

If you cannot patch yet, consider restricting access to the affected module or limiting network access from the server to sensitive internal resources to reduce potential exploitation risk.

Description

Server-Side Request Forgery (SSRF) vulnerability in Drupal OpenID Connect / OAuth client allows Server Side Request Forgery.This issue affects OpenID Connect / OAuth client: from 0.0.0 before 1.5.0.

References

Community reviews

Loading reviews…