CVE-2026-35386: OpenBSD OpenSSH · Incorrect Behavior Order
Affects OpenBSD OpenSSHSource CVE Database V5
Not known to be exploited · CVSS 3.6 Low : upgrade to 10.3 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.3
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade OpenSSH and the Debian debian/openssh package to 10.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenBSDOpenSSH | Affected
| Fixed in
|
Debiandebian/opensshpkg:deb/debian/opensshOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid using untrusted usernames on the command line and refrain from non-default % configurations in ssh_config that could trigger this behavior.
Description
CVE-2026-35386 is a low-severity vulnerability in OpenSSH versions before 10.3 where command execution can occur due to improper handling of shell metacharacters in usernames on the command line. Exploitation requires an untrusted username input and non-default ssh_config settings involving the % character. The vulnerability has a CVSS score of 3.6 and does not have known exploits in the wild.