CVE-2026-35485: oobabooga text-generation-webui · Path Traversal
Affects oobabooga text-generation-webuiSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 4.3 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade text-generation-webui and oobabooga/text-generation-webui to 4.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| oobaboogatext-generation-webui | Affected
| Fixed in
|
GitHuboobabooga/text-generation-webuipkg:github/oobabooga/text-generation-webuiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to text-generation-webui version 4.3 or later, where this path traversal vulnerability is fixed. Patch status is not explicitly confirmed beyond the fix in version 4.3, so users should verify with the vendor or project repository for the latest guidance.
Description
CVE-2026-35485 is a path traversal vulnerability in oobabooga's text-generation-webui versions prior to 4.3. It allows unauthenticated attackers to read arbitrary files on the server by sending crafted directory traversal payloads via the API. The vulnerability arises because the load_grammar() function does not properly restrict pathname access, and Gradio does not validate dropdown input server-side. This issue is fixed in version 4.3. The vulnerability has a high severity score of 7.5 and impacts confidentiality but not integrity or availability.