CVE-2026-35487: oobabooga text-generation-webui · Path Traversal
Affects oobabooga text-generation-webuiSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.3 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade text-generation-webui and oobabooga/text-generation-webui to 4.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| oobaboogatext-generation-webui | Affected
| Fixed in
|
GitHuboobabooga/text-generation-webuipkg:github/oobabooga/text-generation-webuiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to version 4.3 or later of oobabooga text-generation-webui, where this vulnerability is fixed. Since the vulnerability is resolved in the official release, no additional mitigation steps are required beyond applying the update. Patch status is confirmed by the vendor stating the fix is included in version 4.3.
Description
CVE-2026-35487 is a path traversal vulnerability in versions of oobabooga text-generation-webui prior to 4.3. It allows unauthenticated attackers to read arbitrary . txt files on the server by exploiting the load_prompt() function. The file contents are returned directly in the API response. This vulnerability has a medium severity rating and is fixed in version 4.3.