CVE-2026-35490: dgtlmoon changedetection.io · Incorrect Authorization
Affects dgtlmoon changedetection.ioSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.54.8 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.54.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade changedetection.io and dgtlmoon/changedetection.io to 0.54.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dgtlmoonchangedetection.io | Affected
| Fixed in
|
GitHubdgtlmoon/changedetection.iopkg:github/dgtlmoon/changedetection.ioOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade changedetection.io to version 0.54.8 or later, where the decorator order is corrected and authentication is properly enforced. Since this is an open source product and not a cloud service, manual patching by updating to the fixed version is required. Patch status is not explicitly stated in vendor advisories, but the fix is included in version 0.54.8 as per the description.
Description
changedetection.io is a free open source web page change detection tool. Prior to 0.54.8, the @login_optionally_required decorator is placed before (outer to) @blueprint.route() instead of after it. In Flask, @route() must be the outermost decorator because it registers the function it receives. When the order is reversed, @route() registers the original undecorated function, and the auth wrapper is never in the call chain. This silently disables authentication on these routes. This vulnerability is fixed in 0.54.8.