Skip to main content
VulnerabilityPublished

CVE-2026-35492: kedro-plugins · Path Traversal

Affects kedro-pluginsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 9.3.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.3.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade kedro-plugins to 9.3.0.

Affected software

ProductAffectedFixed in
kedro-orgkedro-pluginsAffected
  • <9.3.0
Fixed in
  • 9.3.0
PyPIkedro-pluginspkg:pypi/kedro-pluginsOther threatsAffected
  • <9.3.0
Fixed in
  • 9.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade kedro-plugins to version 9.3.0 or later, where this path traversal vulnerability is fixed. Since this is a cloud-hosted service, the vendor manages remediation server-side. Users should verify with the vendor advisory for confirmation of patch deployment. No additional mitigation actions are specified or required.

Description

CVE-2026-35492 is a path traversal vulnerability in the PartitionedDataset component of kedro-datasets, a plugin for kedro-plugins. Prior to version 9.3.0, the plugin concatenated partition IDs directly with the dataset base path without validating for path traversal sequences like '.. '. This flaw could allow an attacker to write files outside the intended dataset directory, potentially overwriting arbitrary files on the filesystem. The vulnerability affects all storage backends supported by PartitionedDataset, including local filesystems and cloud storage such as S3 and GCS. The issue is fixed in kedro-plugins version 9.3.0.

References

Community reviews

Loading reviews…