CVE-2026-35512: neutrinolabs xrdp · Heap-based Buffer Overflow
Affects neutrinolabs xrdpSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.10.6 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.10.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade xrdp and neutrinolabs/xrdp to 0.10.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| neutrinolabsxrdp | Affected
| Fixed in
|
GitHubneutrinolabs/xrdppkg:github/neutrinolabs/xrdpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade xrdp to version 0.10.6 or later, where this vulnerability is fixed. If immediate upgrade is not feasible, ensure xrdp runs as a non-privileged user (default since version 0.10.2) to limit the impact of potential exploitation. Monitor vendor advisories for any additional guidance.
Description
xrdp is an open source RDP server. Versions through 0.10.5 have a heap-based buffer overflow in the EGFX (graphics dynamic virtual channel) implementation due to insufficient validation of client-controlled size parameters, allowing an out-of-bounds write via crafted PDUs. Pre-authentication exploitation can crash the process, while post-authentication exploitation may achieve remote code execution. This issue has been fixed in version 0.10.6. If users are unable to immediately update, they should run xrdp as a non-privileged user (default since 0.10.2) to limit the impact of successful exploitation.