Skip to main content
VulnerabilityPublished

CVE-2026-35517: pi-hole FTL · OS Command Injection

Affects pi-hole FTLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 6.6 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade FTL and pi-hole/FTL to 6.6.

Affected software

ProductAffectedFixed in
pi-holeFTLAffected
  • >=6.0 <6.6
Fixed in
  • 6.6
GitHubpi-hole/FTLpkg:github/pi-hole/FTLOther threatsAffected
  • <6.6 >=6.0
Fixed in
  • 6.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Pi-hole FTL to version 6.6 or later, where this vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in 6.6, applying this official fix is the recommended remediation. No other mitigation or temporary workaround is documented. Patch status is confirmed fixed in version 6.6.

Description

A high-severity remote code execution vulnerability (CVE-2026-35517) exists in Pi-hole FTL versions 6.0 up to but not including 6.6. The vulnerability arises from improper neutralization of special elements in the upstream DNS servers configuration parameter, allowing an authenticated attacker to inject arbitrary dnsmasq configuration directives via newline characters. This injection can lead to command execution on the underlying system. The issue is fixed in version 6.6. No known exploits in the wild have been reported as of the publication date.

References

Community reviews

Loading reviews…