Skip to main content
VulnerabilityPublished Updated

CVE-2026-35573: ChurchCRM CRM · Path Traversal

Affects ChurchCRM CRMSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 6.5.3 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5.3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade CRM and churchcrm/CRM to 6.5.3.

Affected software

ProductAffectedFixed in
ChurchCRMCRMAffected
  • <6.5.3
Fixed in
  • 6.5.3
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threatsAffected
  • <6.5.3
Fixed in
  • 6.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ChurchCRM to version 6.5.3 or later, where this vulnerability is fixed. Since the vulnerability requires authenticated administrator access, ensure that administrator credentials are protected and access is limited. Patch status is not explicitly stated in the vendor advisory, but the fix is included in version 6.5.3. No other mitigations are documented.

Description

A critical path traversal vulnerability (CWE-22) exists in ChurchCRM versions prior to 6.5.3 within the backup restore functionality. Authenticated administrators can exploit this flaw by uploading files with arbitrary names, enabling overwriting of Apache . htaccess files and potentially achieving remote code execution. The issue is due to improper validation of the filename parameter in RestoreJob.php. This vulnerability has a CVSS score of 9.1 and is fixed in version 6.5.

References

Community reviews

Loading reviews…