Skip to main content
VulnerabilityPublished Updated

CVE-2026-3904: The GNU C Library glibc · Race Condition Within a Thread

Affects The GNU C Library glibcSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.2 Medium : upgrade to 2.37 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.37
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade The GNU C Library glibc to 2.37.

Affected software

ProductAffectedFixed in
The GNU C LibraryglibcAffected
  • >=2.35 <2.37
Fixed in
  • 2.37
Debiandebian/glibcpkg:deb/debian/glibcOther threatsAffected
  • =2.35
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix has been backported to all vulnerable branches of the GNU C Library repository. It is recommended that distributions using glibc versions 2.35 and 2.36, especially those that have cherry-picked the memcpy SSE2 optimization, apply the official patches to prevent crashes. Patch status is not explicitly confirmed in the provided data; therefore, check the vendor advisory for the latest remediation guidance.

Description

Calling NSS-backed functions that support caching via nscd may call the nscd client side code and in the GNU C Library version 2.36 under high load on x86_64 systems, the client may call memcmp on inputs that are concurrently modified by other processes or threads and crash. The nscd client in the GNU C Library uses the memcmp function with inputs that may be concurrently modified by another thread, potentially resulting in spurious cache misses, which in itself is not a security issue. However in the GNU C Library version 2.36 an optimized implementation of memcmp was introduced for x86_64 which could crash when invoked with such undefined behaviour, turning this into a potential crash of the nscd client and the application that uses it. This implementation was backported to the 2.35 branch, making the nscd client in that branch vulnerable as well. Subsequently, the fix for this issue was backported to all vulnerable branches in the GNU C Library repository. It is advised that distributions that may have cherry-picked the memcpy SSE2 optimization in their copy of the GNU C Library, also apply the fix to avoid the potential crash in the nscd client.

References

Community reviews

Loading reviews…