Skip to main content
VulnerabilityPublished Updated

CVE-2026-39324: rack-session · Improper Authentication

Affects rack-sessionSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.1.2 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade rack-session to 2.1.2.

Affected software

ProductAffectedFixed in
rackrack-sessionAffected
  • >=2.0.0 <2.1.2
Fixed in
  • 2.1.2
RubyGemsrack-sessionpkg:gem/rack-sessionOther threatsAffected
  • <2.1.2 >=2.0.0
Fixed in
  • 2.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade rack-session to version 2.1.2 or later, where this vulnerability is fixed. Patch status is not explicitly stated in the vendor advisory content, but the description confirms the fix in 2.1.2. No other mitigations are indicated.

Description

CVE-2026-39324 is a critical improper authentication vulnerability in rack-session versions 2.0.0 up to but not including 2.1.2. The vulnerability arises because Rack::Session::Cookie incorrectly handles decryption failures by falling back to a default decoder instead of rejecting the cookie. This flaw allows an unauthenticated attacker to supply a crafted session cookie that is accepted as valid without knowing any configured secret, enabling manipulation of session contents and potential unauthorized access. The issue is fixed in version 2.1.2.

References

Community reviews

Loading reviews…