CVE-2026-39337: ChurchCRM CRM · Code Injection
Affects ChurchCRM CRMSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 10.0 Critical : upgrade to 7.1.0 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade CRM and churchcrm/CRM to 7.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ChurchCRMCRM | Affected
| Fixed in
|
GitHubchurchcrm/CRMpkg:github/churchcrm/CRMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ChurchCRM to version 7.1.0 or later, where this vulnerability is fixed. No other official remediation or temporary fix is indicated. Patch status is confirmed by the vendor advisory stating the issue is resolved in 7.1.0.
Description
ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.