CVE-2026-39355: MGeurts genealogy · Missing Authorization
Affects MGeurts genealogySource CVE Database V5
Not known to be exploited · CVSS 10.0 Critical : upgrade to 5.9.1 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade genealogy and mgeurts/genealogy to 5.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MGeurtsgenealogy | Affected
| Fixed in
|
GitHubmgeurts/genealogypkg:github/mgeurts/genealogyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the MGeurts genealogy application to version 5.9.1 or later, where this vulnerability is fixed. Until upgraded, restrict authenticated user privileges as much as possible to limit exposure.
Description
A critical broken access control vulnerability (CWE-862) exists in MGeurts genealogy versions prior to 5.9.1. This flaw allows any authenticated user to transfer ownership of arbitrary non-personal teams to themselves, resulting in complete takeover of other users' team workspaces and full access to all associated genealogy data. The vulnerability is fixed in version 5.9.1. No known exploits are reported in the wild as of the publication date.