CVE-2026-41148: mermaid · Code Injection
Affects mermaidSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 11.15.0 or 10.9.6 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.15.0, 10.9.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 22 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mermaid to 11.15.0 or 10.9.6; mermaid-js/mermaid to 10.9.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mermaid-jsmermaid | Affected
| Fixed in
|
| mermaid-jsmermaid | Affected
| Fixed in
|
npmmermaid-js/mermaidpkg:npm/mermaid-js/mermaidOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in mermaid versions 10.9.6 and 11.15.0. Users and developers should upgrade to these versions to remediate the vulnerability. If immediate upgrade is not feasible, setting the configuration option "securityLevel" to "sandbox" provides a temporary workaround by rendering diagrams inside a sandboxed iframe, preventing CSS injection exploitation.
Description
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and prior, in addition to 11.0.0-alpha.1 through 11.12.0 are vulnerable to CSS injection through improper sanitization. The state diagram (and any other diagram type that routes user-controlled style strings through the createCssStyles parser) captures classDef values using an unrestricted regex that matches everything up to a newline. That value then flows unsanitized through addStyleClass() into createCssStyles() and is assigned to style.innerHTML, so a closing brace (}) in the value terminates the generated CSS selector and turns everything after it into a new CSS rule on the page. This enables page defacement, user tracking via url() callbacks, and DOM attribute exfiltration. This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.
References
- github.com/mermaid-js/mermaid/security/advisories/GHSA-xcj9-5m2h-648r (opens in a new tab)
- github.com/mermaid-js/mermaid/commit/8fead23c59166b7bab6a39eac81acebee2859102 (opens in a new tab)
- github.com/mermaid-js/mermaid/commit/e9b0f34d8d82a6260077764ee45e1d7d90957a0f (opens in a new tab)
- github.com/mermaid-js/mermaid/releases/tag/mermaid%4011.15.0 (opens in a new tab)
- github.com/mermaid-js/mermaid/releases/tag/v10.9.6 (opens in a new tab)
- mermaid.js.org/config/schema-docs/config.html (opens in a new tab)