Skip to main content
VulnerabilityPublished

CVE-2026-39379: core-geonetwork · Cross-site Scripting

Affects core-geonetworkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 4.4.10 or 4.2.15 soon.

Data as of 3 Nov 2026, 19:13 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.1
Patch
Available – fixed in 4.4.10, 4.2.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade core-geonetwork to 4.4.10 or 4.2.15.

Affected software

ProductAffectedFixed in
geonetworkcore-geonetworkAffected
  • >=3.0.0 <=3.12.12
  • >=4.0.0-alpha.1 <=4.0.6
  • >=4.2.0 <4.2.15
  • >=4.4.0 <4.4.10
Fixed in
  • 4.4.10
  • 4.2.15

AI-suggested

Upgrade to GeoNetwork core-geonetwork versions 4.2.15 or 4.4.10 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

GeoNetwork core-geonetwork versions from 3.0.0 up to 4.2.15 and 4.4.10 are vulnerable to a cross-site scripting (XSS) flaw. This occurs when a nonexistent or unauthorized service URL causes an error page to reflect attacker-controlled input inside an AngularJS application without proper sanitization. An attacker can craft a link that, when opened by a victim, including administrators, executes arbitrary JavaScript in the victim's authenticated browser session. This vulnerability is fixed in versions 4.2.15 and 4.4.10.

References

Community reviews

Loading reviews…