CVE-2026-55864: core-geonetwork · Server-Side Request Forgery (SSRF)
Affects core-geonetworkSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 7.8 High : upgrade to 4.4.12 or 4.2.17 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.12, 4.2.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: evidence found.
nuclei template: GeoNetwork - Server-Side Request Forgery (SSRF)
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade core-geonetwork and geonetwork/core-geonetwork to 4.4.12 or 4.2.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| geonetworkcore-geonetwork | Affected
| Fixed in
|
| geonetworkcore-geonetwork | Affected
| Fixed in
|
GitHubgeonetwork/core-geonetworkpkg:github/geonetwork/core-geonetworkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in GeoNetwork core-geonetwork versions 4.2.17 and 4.4.12. Users should upgrade to these versions or later to remediate the issue. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
GeoNetwork core-geonetwork versions prior to 4.2.17 and 4.4.12 contain a server-side request forgery (SSRF) vulnerability in the POST /api/tools/ogc/sld endpoint. This endpoint accepted a user-supplied WMS server URL and performed an HTTP GET request without validating the destination. An anonymous attacker could exploit this to make the server send requests to internal, non-publicly reachable hosts. If the response was XML, the server could store and return the fetched content, enabling internal data disclosure, authorization bypass, and network reconnaissance. The vulnerability is fixed in versions 4.2.17 and 4.4.12.
References
- github.com/geonetwork/core-geonetwork/security/advisories/GHSA-5hx7-j24v-rffj (opens in a new tab)
- github.com/geonetwork/core-geonetwork/pull/9343 (opens in a new tab)
- github.com/geonetwork/core-geonetwork/pull/9344 (opens in a new tab)
- github.com/geonetwork/core-geonetwork/commit/17fdae28a5a51996bf5ff7f7e8236332c74eab77 (opens in a new tab)
- github.com/geonetwork/core-geonetwork/commit/a80d535c842e6af589d0bac37e7fe4ba01193757 (opens in a new tab)
- github.com/geonetwork/core-geonetwork/releases/tag/4.2.17 (opens in a new tab)
- github.com/geonetwork/core-geonetwork/releases/tag/4.4.12 (opens in a new tab)