Skip to main content
VulnerabilityPublished

CVE-2026-39423: 1Panel-dev MaxKB · Cross-site Scripting

Affects 1Panel-dev MaxKBSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.8.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade MaxKB and 1panel-dev/MaxKB to 2.8.0.

Affected software

ProductAffectedFixed in
1Panel-devMaxKBAffected
  • <2.8.0
Fixed in
  • 2.8.0
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threatsAffected
  • <2.8.0
Fixed in
  • 2.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade MaxKB to version 2.8.0 or later, where this vulnerability has been fixed. Since this is not a cloud service, remediation depends on applying the official update. Patch status is confirmed by the vendor's versioning information. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-39423 is a stored cross-site scripting (XSS) vulnerability in MaxKB versions 2.7.1 and below. It arises from an Eval Injection flaw in the Markdown rendering engine, allowing users interacting with the AI chat interface to execute arbitrary JavaScript in other users' browsers, including administrators. This vulnerability has been fixed in version 2.8.0. The CVSS 4.0 base score is 6.9, indicating medium severity.

References

Community reviews

Loading reviews…