CVE-2026-40166: goauthentik authentik · Information Exposure
Affects goauthentik authentikSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 2026.2.3 or 2025.12.5 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.2.3, 2025.12.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade authentik to 2026.2.3 or 2025.12.5; github.com/goauthentik/authentik to 2025.12.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| goauthentikauthentik | Affected
| Fixed in
|
| goauthentikauthentik | Affected
| Fixed in
|
Gogithub.com/goauthentik/authentikpkg:golang/github.com/goauthentik/authentikOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in authentik versions 2025.12.5 and 2026.2.3. Users should upgrade to one of these versions or later to remediate the issue. Since this is not a cloud service, remediation depends on applying the official patch. Patch status is confirmed fixed in these versions. No additional mitigations are indicated by the vendor advisory.
Description
authentik is an open-source identity provider. In versions prior to 2025.12.5 and 2026.2.0-rc1 through 2026.2.2, authenticated non-admin users with at least one OAuth2 access token can retrieve the client_secret of confidential OAuth2 providers they have previously authenticated against, exposing sensitive information to users without the correct permissions. This logic is GET /api/v3/oauth2/access_tokens/. The API response includes a nested provider object containing client_id and client_secret for providers configured with client_type: confidential, which should not be accessible to low-privilege users. This issue has been fixed in versions 2025.12.5 and 2026.2.3.