CVE-2026-41084: Apache Airflow · Insecure Direct Object Reference
Affects Apache AirflowSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow to 3.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
PyPIapache-airflowpkg:pypi/apache-airflowOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apache Airflow version 3.2.2 and later. Users should upgrade affected deployments from version 3.2.0 to 3.2.2 or newer to remediate this authorization bypass vulnerability. No other mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-41084 is an authorization bypass vulnerability in Apache Airflow's bulk Task Instances API. The API incorrectly authorizes requests based on the dag_id in the URL path while processing task instances for dag_id and dag_run_id values from the request body. This allows an authenticated user with edit permissions on one DAG to modify task instance states in other DAGs by manipulating the request body. The issue affects deployments that enforce per-DAG edit scopes to isolate task instance state changes between teams. The vulnerability is present in Apache Airflow version 3.2.0. Users are advised to upgrade to version 3.2.2 or later to remediate the issue.