Skip to main content
VulnerabilityPublished

CVE-2026-41182: langchain-ai langsmith-sdk · Information Exposure

Affects langchain-ai langsmith-sdkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.7.31 or 0.5.19 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.7.31, 0.5.19
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade langsmith-sdk to 0.7.31 or 0.5.19; langsmith-sdk to 0.7.31; langchain-ai/langsmith-sdk to 0.5.19.

Affected software

ProductAffectedFixed in
langchain-ailangsmith-sdkAffected
  • <0.7.31
Fixed in
  • 0.7.31
langchain-ailangsmith-sdkAffected
  • <0.5.19
Fixed in
  • 0.5.19
npmlangchain-ai/langsmith-sdkpkg:npm/langchain-ai/langsmith-sdkOther threatsAffected
  • <0.5.19
Fixed in
  • 0.5.19
PyPIlangsmith-sdkpkg:pypi/langsmith-sdkOther threatsAffected
  • <0.7.31
Fixed in
  • 0.7.31

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to langsmith-sdk JavaScript version 0.5.19 or later and Python version 0.7.31 or later. These versions fix the issue by applying output redaction controls to streaming token events. No other mitigation is indicated or required.

Description

CVE-2026-41182 is a vulnerability in the langchain-ai langsmith-sdk JavaScript and Python SDKs prior to versions 0.5.19 and 0.7.31 respectively. The issue arises because output redaction controls do not apply to streaming token events, allowing raw token values from streaming LLM outputs to be recorded and stored without redaction. This results in unintended exposure of sensitive information through run event data. The vulnerability has a CVSS score of 5.3, indicating medium severity. Fixed versions are available that address this issue by properly applying redaction to streaming events.

References

Community reviews

Loading reviews…