Skip to main content
VulnerabilityPublished

CVE-2026-41990: gnupg Libgcrypt · Out-of-bounds Write

Affects gnupg LibgcryptSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.0 Medium : upgrade to 1.12.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.2
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gnupg Libgcrypt to 1.12.2.

Affected software

ProductAffectedFixed in
gnupgLibgcryptAffected
  • >=1.12.0 <1.12.2
Fixed in
  • 1.12.2

AI-suggested

If you cannot patch yet, users should consider upgrading to Libgcrypt 1.12.2 or later once available. No other specific mitigations are indicated by the vendor or advisory.

Description

CVE-2026-41990 is a medium-severity vulnerability in Libgcrypt versions before 1.12.2. It involves an out-of-bounds write related to Dilithium signing where writes to a static array lack proper bounds checking. However, the data written is not attacker-controlled, which limits the potential impact.

References

Community reviews

Loading reviews…