Skip to main content
VulnerabilityPublished

CVE-2026-41208: @paperclipai/server · OS Command Injection

Affects @paperclipai/serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2026.416.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.416.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade @paperclipai/server to 2026.416.0.

Affected software

ProductAffectedFixed in
paperclipai@paperclipai/serverAffected
  • <2026.416.0
Fixed in
  • 2026.416.0
npm@paperclipai/serverpkg:npm/@paperclipai/serverOther threatsAffected
  • <2026.416.0
Fixed in
  • 2026.416.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade @paperclipai/server to version 2026.416.0 or later, where this vulnerability is fixed. Since the vendor advisory confirms the fix in this version, applying this update is the recommended remediation. Patch status is not explicitly stated beyond this version, so verify with the vendor advisory for any additional guidance.

Description

CVE-2026-41208 is a high-severity OS command injection vulnerability in versions of @paperclipai/server prior to 2026.416.0. It allows an attacker with an Agent API key to escalate privileges by injecting arbitrary shell commands through the adapterConfig.workspaceStrategy.provisionCommand field. This leads to remote code execution on the Paperclip server host. The vulnerability arises because the server executes this provisionCommand without proper neutralization of special elements, breaking the trust boundary between agent runtime and server host. The issue is fixed in version 2026.416.

References

Community reviews

Loading reviews…