Skip to main content
VulnerabilityPublished

CVE-2026-41276: FlowiseAI Flowise · Improper Authentication

Affects FlowiseAI FlowiseSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 3.1.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.8% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Flowise and flowiseai/Flowise to 3.1.0.

Affected software

ProductAffectedFixed in
FlowiseAIFlowiseAffected
  • <3.1.0
Fixed in
  • 3.1.0
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threatsAffected
  • <3.1.0
Fixed in
  • 3.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Flowise version 3.1.0. Users and administrators should upgrade to version 3.1.0 or later to remediate this vulnerability. Since the vendor advisory does not indicate any temporary or alternative mitigations, applying the official update is the recommended course of action.

Description

CVE-2026-41276 is an improper authentication vulnerability in FlowiseAI Flowise versions prior to 3.1.0. It allows remote attackers to reset any user's password without authentication by exploiting a flaw in the resetPassword method of the AccountService class. The system fails to verify that a valid password reset token was generated before allowing a password reset. An attacker who knows a user's email can submit a reset request with a null or empty token and arbitrarily set a new password. This vulnerability is fixed in version 3.1.0.

References

Community reviews

Loading reviews…