CVE-2026-41324: patrickjuchli basic-ftp · Uncontrolled Resource Consumption
Affects patrickjuchli basic-ftpSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 5.3.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade patrickjuchli basic-ftp to 5.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| patrickjuchlibasic-ftp | Affected
| Fixed in
|
npmbasic-ftppkg:npm/basic-ftpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade basic-ftp to version 5.3.0 or later, where this vulnerability is fixed. There is no official vendor advisory provided, but the description explicitly states that version 5.3.0 addresses the issue. Patch status is confirmed by the version upgrade requirement. No additional mitigations are indicated.
Description
basic-ftp versions prior to 5.3.0 contain a vulnerability where processing directory listings from a remote FTP server can lead to unbounded memory growth. A malicious or compromised FTP server can send an extremely large or never-ending directory listing response to the Client.list() method, causing the client to consume excessive memory and potentially crash or become unstable. This denial of service vulnerability is fixed in version 5.3.0.