Skip to main content
VulnerabilityPublished

CVE-2026-41325: getkirby kirby · Incorrect Authorization

Affects getkirby kirbySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 5.4.0 or 4.9.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.0, 4.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade kirby to 5.4.0 or 4.9.0; getkirby/kirby to 4.9.0.

Affected software

ProductAffectedFixed in
getkirbykirbyAffected
  • >=5.0.0 <5.4.0
Fixed in
  • 5.4.0
getkirbykirbyAffected
  • <4.9.0
Fixed in
  • 4.9.0
GitHubgetkirby/kirbypkg:github/getkirby/kirbyOther threatsAffected
  • <4.9.0
Fixed in
  • 4.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Kirby versions 4.9.0 and 5.4.0 and later. Users should upgrade to these or newer versions to remediate the issue. Patch status is not explicitly confirmed beyond the version fixes mentioned; users should verify with the vendor for the latest remediation guidance.

Description

CVE-2026-41325 is a high-severity vulnerability in the Kirby CMS prior to versions 4.9.0 and 5.4.0. It involves incorrect authorization due to the ability to override user permissions during the creation of pages, files, and users by injecting custom dynamic blueprint configurations. This flaw allowed attackers with limited privileges to bypass intended permission restrictions by injecting an 'options' property with 'create' set to true. The issue has been fixed in Kirby versions 4.9.0 and 5.

References

Community reviews

Loading reviews…