CVE-2026-41416: pjsip pjproject · Integer Overflow or Wraparound
Affects pjsip pjprojectSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.17 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade pjproject and pjsip/pjproject to 2.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pjsippjproject | Affected
| Fixed in
|
GitHubpjsip/pjprojectpkg:github/pjsip/pjprojectOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to pjproject version 2.17 or later, where this integer overflow vulnerability has been fixed. Patch status is not explicitly confirmed beyond the stated fix in version 2.17, so checking the vendor advisory for current remediation guidance is recommended.
Description
PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an integer overflow in media stream buffer size calculation when processing SDP with asymmetric ptime configuration. The overflow may result in an undersized buffer allocation, which can lead to unexpected application termination or memory corruption This vulnerability is fixed in 2.17.