Skip to main content
VulnerabilityPublished Updated

CVE-2026-41432: QuantumNous new-api · Insufficient Verification of Data Authenticity

Affects QuantumNous new-apiSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 7.1 High : upgrade to 0.12.10 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade new-api and quantumnous/new-api to 0.12.10.

Affected software

ProductAffectedFixed in
QuantumNousnew-apiAffected
  • <0.12.10
Fixed in
  • 0.12.10
GitHubquantumnous/new-apipkg:github/quantumnous/new-apiOther threatsAffected
  • <0.12.10
Fixed in
  • 0.12.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in QuantumNous new-api version 0.12.10. Users should upgrade to this version or later to remediate the vulnerability. Since this is not a cloud service, remediation depends on applying the patch. Patch status is confirmed by the vendor advisory indicating the issue is fixed in version 0.12.10.

Description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to version 0.12.10, a vulnerability exists in the Stripe webhook handler that allows an unauthenticated attacker to forge webhook events and credit arbitrary quota to their account without making any payment. This issue has been patched in version 0.12.10.

References

Community reviews

Loading reviews…