Skip to main content
VulnerabilityPublished Updated

CVE-2026-41472: usmannasir cyberpanel · Cross-site Scripting

Affects usmannasir cyberpanelSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.4.5 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.5, 2.4.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cyberpanel to 2.4.5; usmannasir/cyberpanel to 2.4.4.

Affected software

ProductAffectedFixed in
usmannasircyberpanelAffected
  • <2.4.5
Fixed in
  • 2.4.5
GitHubusmannasir/cyberpanelpkg:github/usmannasir/cyberpanelOther threatsAffected
  • <2.4.4
Fixed in
  • 2.4.4
GitHubcyberpanelpkg:github/cyberpanelOther threatsAffected
  • <2.4.5
Fixed in
  • 2.4.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the AI Scanner dashboard and monitor for unauthorized POST requests to the /api/ai-scanner/callback endpoint. Consider implementing additional authentication or input validation controls to mitigate exploitation.

Description

CyberPanel versions prior to 2.4.5 contain a stored cross-site scripting vulnerability in the AI Scanner dashboard where the POST /api/ai-scanner/callback endpoint lacks authentication and allows unauthenticated attackers to inject malicious JavaScript by overwriting the findings_json field of ScanHistory records. Attackers can inject JavaScript that executes in an administrator's authenticated session when they visit the AI Scanner dashboard, allowing them to issue same-origin requests to plant cron jobs and achieve remote code execution on the server.

References

Community reviews

Loading reviews…