Skip to main content
VulnerabilityPublished

CVE-2026-4148: MongoDB Server · Use After Free

Affects MongoDB ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High · fixed in 8.2.6 : patch MongoDB Server soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.2.6, 8.0.20, 7.0.31
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade MongoDB Server to 8.2.6, 8.0.20 or 7.0.31.

Affected software

ProductAffectedFixed in
MongoDB IncMongoDB ServerAffected
  • >=8.2 <8.2.6
Fixed in
  • 8.2.6
MongoDB IncMongoDB ServerAffected
  • >=8.0 <8.0.20
Fixed in
  • 8.0.20
MongoDB IncMongoDB ServerAffected
  • >=7.0 <7.0.31
Fixed in
  • 7.0.31

AI-suggested

Organizations should immediately assess their MongoDB deployments to identify if they are running affected versions (7.0, 8.0, 8.2) in sharded cluster configurations. In the interim, restrict read role access strictly to trusted users and audit all users with read privileges in sharded clusters. Implement network segmentation and access controls to limit exposure of MongoDB instances to untrusted networks. Disable or restrict the use of $lookup and $graphLookup aggregation stages for users who do not require them. Employ runtime monitoring and anomaly detection to identify unusual aggregation queries that could indicate exploitation attempts. Regularly back up data and have incident response plans ready to mitigate potential exploitation consequences. Consider upgrading to newer MongoDB versions if they include fixes for this vulnerability.

Description

CVE-2026-4148 is a high-severity use-after-free vulnerability in MongoDB Server versions 7.0, 8.0, and 8.2. It can be exploited by an authenticated user with read role privileges in sharded clusters by issuing a specially crafted $lookup or $graphLookup aggregation pipeline. This vulnerability does not require user interaction or elevated privileges beyond read access but can lead to high impact on confidentiality, integrity, and availability. No known exploits are currently reported in the wild. The vulnerability stems from improper memory management (CWE-416) during aggregation operations in sharded environments. Organizations using affected MongoDB versions in sharded configurations should prioritize patching or mitigating this issue to prevent potential exploitation. The CVSS 4.

References

Community reviews

Loading reviews…