CVE-2026-41720: Spring LDAP · Improper Authentication
Affects Spring LDAPSource CVE Database V5
Not known to be exploited · CVSS 7.4 High · fixed in 4.0.3.1 : patch Spring LDAP soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.3.1, 3.3.7.1, 3.2.18 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Spring LDAP to 4.0.3.1, 3.3.7.1, 3.2.18 or 2.4.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring LDAP | Affected
| Fixed in
|
| SpringSpring LDAP | Affected
| Fixed in
|
| SpringSpring LDAP | Affected
| Fixed in
|
| SpringSpring LDAP | Affected
| Fixed in
|
Mavenorg.springframework.ldap/spring-ldappkg:maven/org.springframework.ldap/spring-ldapOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should consider additional authentication validation controls or restrict access to vulnerable Spring LDAP instances.
Description
CVE-2026-41720 is a high-severity vulnerability in Spring LDAP where certain DirContextAuthenticationStrategy implementations improperly accept bind requests with a non-empty username and an empty or null password. This affects multiple versions of Spring LDAP, specifically 2.4.0 through 2.4.4, 3.2.0 through 3.2.17, 3.3.0 through 3.3.7, and 4.0.0 through 4.0.3. The vulnerability relates to improper authentication (CWE-287) and could allow unauthorized access if exploited.