Skip to main content
VulnerabilityPublished

CVE-2026-41900: th30d4y OpenLearnX · OS Command Injection

Affects th30d4y OpenLearnXSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.0.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade OpenLearnX and th30d4y/OpenLearnX to 2.0.3.

Affected software

ProductAffectedFixed in
th30d4yOpenLearnXAffected
  • <2.0.3
Fixed in
  • 2.0.3
GitHubth30d4y/OpenLearnXpkg:github/th30d4y/OpenLearnXOther threatsAffected
  • <2.0.3
Fixed in
  • 2.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenLearnX to version 2.0.3 or later, where this vulnerability has been patched. No other mitigation steps are indicated or required as the fix addresses the root cause.

Description

CVE-2026-41900 is a high-severity vulnerability in the OpenLearnX platform prior to version 2.0.3. It involves improper neutralization of special elements in OS commands, leading to remote code execution and sandbox escape in the code execution environment. This allows an attacker with limited privileges to execute arbitrary commands on the host system. The vulnerability has been patched in OpenLearnX version 2.0.3.

References

Community reviews

Loading reviews…