CVE-2026-41902: freescout · Insufficient Session Expiration
Affects freescoutSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.8.217 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.217
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade freescout and freescout-help-desk/freescout to 1.8.217.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| freescout-help-deskfreescout | Affected
| Fixed in
|
GitHubfreescout-help-desk/freescoutpkg:github/freescout-help-desk/freescoutOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FreeScout to version 1.8.217 or later, where this vulnerability has been patched by implementing expiration checks on the invite_hash. Until upgraded, treat invite emails as highly sensitive and avoid forwarding or exposing them. Review and revoke any outstanding invite hashes if possible. Patch status is not explicitly stated in the vendor advisory but the description confirms the issue is fixed in version 1.8.217.
Description
FreeScout versions prior to 1.8.217 contain a critical vulnerability in the /user-setup/{hash} endpoint where the invite_hash used for setting a new user's password does not expire. This allows an attacker who obtains a leaked invite hash to perform a permanent unauthenticated account takeover, potentially gaining admin access if the invite was for an admin user. The issue has been fixed in version 1.8.217.