CVE-2026-41988: uuidjs uuid · Always-Incorrect Control Flow Implementation
Affects uuidjs uuidSource CVE Database V5
Not known to be exploited · CVSS 3.2 Low : upgrade to 14.0.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 14.0.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade uuidjs uuid to 14.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| uuidjsuuid | Affected
| Fixed in
|
npmuuidpkg:npm/uuidOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, users should avoid using UUID versions 3, 5, or 6 with external output buffers in uuidjs versions prior to 14.0.0.
Description
The uuidjs library versions before 14.0.0 contain a vulnerability (CVE-2026-41988) where unexpected writes can occur when using external output buffers with UUID versions 3, 5, or 6. This issue does not affect the commonly used UUID version 4. The vulnerability is classified under CWE-670, indicating always-incorrect control flow implementation. The CVSS score is low (3.2), reflecting limited impact and complexity in exploitation.