Skip to main content
VulnerabilityPublished

CVE-2026-42138: langgenius dify · Cross-site Scripting

Affects langgenius difySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.13.1 when convenient.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.13.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade dify and langgenius/dify to 1.13.1.

Affected software

ProductAffectedFixed in
langgeniusdifyAffected
  • <1.13.1
Fixed in
  • 1.13.1
GitHublanggenius/difypkg:github/langgenius/difyOther threatsAffected
  • <1.13.1
Fixed in
  • 1.13.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Dify to version 1.13.1 or later, where this vulnerability is patched. Since the vendor advisory confirms the fix in 1.13.1, applying this update fully mitigates the issue. No additional vendor guidance is provided, so remediation relies on upgrading.

Description

Dify is an open-source LLM app development platform. Prior to version 1.13.1, using the method POST /api/files/upload, any unauthenticated user can upload an SVG file with XSS. The method POST /v1/files/upload, which requires authentication through the application API, is also vulnerable. This issue has been patched in version 1.13.1.

References

Community reviews

Loading reviews…