Skip to main content
VulnerabilityPublished Updated

CVE-2026-42192: useplunk plunk · Cross-site Scripting

Affects useplunk plunkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 0.9.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade plunk and useplunk/plunk to 0.9.0.

Affected software

ProductAffectedFixed in
useplunkplunkAffected
  • <0.9.0
Fixed in
  • 0.9.0
GitHubuseplunk/plunkpkg:github/useplunk/plunkOther threatsAffected
  • <0.9.0
Fixed in
  • 0.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch addressing this vulnerability is available in useplunk plunk version 0.9.0. Since the product is a cloud-hosted service, the vendor manages remediation and patch deployment server-side. Users should ensure they are using version 0.9.0 or later to mitigate this issue. Check the vendor advisory for confirmation of patch deployment status. No additional mitigation steps are indicated by the vendor advisory.

Description

Plunk is an open-source email platform built on top of AWS SES. Prior to version 0.9.0, a stored cross-site scripting (XSS) vulnerability exists in the campaign management feature, where the email body content created by authenticated project members is stored and later rendered in the admin dashboard using React's dangerouslySetInnerHTML without any HTML sanitization. This allows a lower-privileged member to embed malicious scripts in a campaign's email body that execute in the context of any admin or other member who views the campaign, potentially enabling session hijacking or unauthorized actions on their behalf. This issue has been patched in version 0.9.0.

References

Community reviews

Loading reviews…