Skip to main content
VulnerabilityPublished Updated

CVE-2026-42214: dail8859 NotepadNext · Code Injection

Affects dail8859 NotepadNextSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 0.14 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.14
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NotepadNext and dail8859/NotepadNext to 0.14.

Affected software

ProductAffectedFixed in
dail8859NotepadNextAffected
  • <0.14
Fixed in
  • 0.14
GitHubdail8859/NotepadNextpkg:github/dail8859/NotepadNextOther threatsAffected
  • <0.14
Fixed in
  • 0.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade NotepadNext to version 0.14 or later, where this vulnerability has been patched. No other mitigations are specified or required once the update is applied.

Description

CVE-2026-42214 is a code injection vulnerability in NotepadNext versions prior to 0.14. The detectLanguageFromExtension() function unsafely interpolates a file extension into a Lua script without sanitization, allowing an attacker to execute arbitrary Lua code by crafting a malicious file extension. Because the full Lua standard libraries are loaded, this can lead to arbitrary command execution. This vulnerability has been patched in NotepadNext version 0.14.

References

Community reviews

Loading reviews…