CVE-2026-42253: Apache ActiveMQ · Cross-site Scripting
Affects Apache ActiveMQSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 6.2.6 or 5.19.7 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.6, 5.19.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache ActiveMQ and Apache ActiveMQ Web and org.apache.activemq/activemq and Apache Software Foundation/org.apache.activemq:apache-activemq and Apache Software Foundation/org.apache.activemq:activemq-web and org.apache.activemq/activemq-web to 6.2.6 or 5.19.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Web | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Web | Affected
| Fixed in
|
Mavenorg.apache.activemq/activemqpkg:maven/org.apache.activemq/activemqOther threats | Affected
| Fixed in
|
MavenApache Software Foundation/org.apache.activemq:apache-activemqpkg:maven/Apache Software Foundation/org.apache.activemq:apache-activemqOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading Apache ActiveMQ to version 5.19.7 or 6.2.6 or later. These versions deprecate and disable the vulnerable MessageServlet by default, eliminating the attack vector. Users should apply these official updates promptly. No additional mitigations are specified or required once the upgrade is applied.
Description
Apache ActiveMQ contains a cross-site scripting (XSS) vulnerability in its web console API's MessageServlet. The servlet copies JMS message properties into HTTP response headers without validation, allowing potential injection or overwriting of security headers. This affects Apache ActiveMQ versions before 5.19.7 and versions from 6.0.0 before 6.2.6. The vulnerability has a medium severity rating with a CVSS score of 6.1. The MessageServlet has been deprecated and disabled by default in fixed versions. Users are advised to upgrade to Apache ActiveMQ 5.19.7 or 6.2.6 or later to remediate this issue.