CVE-2026-42271: BerriAI litellm · Command Injection
Affects BerriAI litellmSource CVE Database V5
Exploited in the wild · KEV due 22 Jun 2026 · public exploit available (Metasploit) · 91% EPSS : upgrade to 1.83.7 now.
Data as of 30 Oct 2026, 11:52 UTC
- KEV deadline
- US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
- EPSS
- 91.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.83.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: evidence found.
Weaponized: evidence found.
Exploited in the wildExploited: evidence found.
Listed in CISA KEV 31 days after disclosure
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 12 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 16 minutes after disclosure
Added to CISA KEV (opens in a new tab)
exploitation confirmed
, 31 days after disclosure
KEV remediation due
US federal deadline
, 45 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade litellm and berriai/litellm to 1.83.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BerriAIlitellm | Affected
| Fixed in
|
GitHubberriai/litellmpkg:github/berriai/litellmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
CVE-2026-42271 is a command injection vulnerability in BerriAI's LiteLLM proxy server versions 1.74.2 up to but not including 1.83.7. Two endpoints allowed authenticated users, including those with low-privilege API keys, to execute arbitrary commands on the proxy host by submitting crafted server configurations. This flaw arises from insufficient role checks and improper neutralization of command execution parameters. The vulnerability has been patched in version 1.83.7.
References
- github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g (opens in a new tab)
- github.com/BerriAI/litellm/releases/tag/v1.83.7-stable (opens in a new tab)
- cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-42271 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2467924 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:28960 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:30056 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:27784 (opens in a new tab)