Skip to main content
CVE-2026-42302VulnerabilityPublished Updated

CVE-2026-42302: labring FastGPT · Missing Authentication

Affects labring FastGPTSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.14.13 as a priority.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.14.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade FastGPT and labring/FastGPT to 4.14.13.

Affected software

ProductAffectedFixed in
labringFastGPTAffected
  • >=4.14.10 <4.14.13
Fixed in
  • 4.14.13
GitHublabring/FastGPTpkg:github/labring/FastGPTOther threatsAffected
  • >=4.14.10 <4.14.13
Fixed in
  • 4.14.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FastGPT to version 4.14.13 or later, where this vulnerability has been patched. Since this is not a cloud service, users must apply the update themselves to remediate the issue. Patch status is confirmed by the vendor's versioning information.

Description

FastGPT is an AI Agent building platform. From version 4.14.10 to before version 4.14.13, the agent-sandbox component of FastGPT is vulnerable to unauthenticated Remote Code Execution (RCE). The startup script entrypoint.sh initializes code-server with the --auth none flag and binds the service to all network interfaces (0.0.0.0:8080). This configuration allows any user with network access to the port to bypass authentication and gain full control over the sandbox environment. This issue has been patched in version 4.14.13.

References

Community reviews

Loading reviews…