CVE-2026-42463: dataease SQLBot · Insecure Direct Object Reference
Affects dataease SQLBotSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.8.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade SQLBot and dataease/SQLBot to 1.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dataeaseSQLBot | Affected
| Fixed in
|
GitHubdataease/SQLBotpkg:github/dataease/SQLBotOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SQLBot to version 1.8.0 or later, where this authorization bypass vulnerability is fixed. Since the vendor advisory confirms the fix in version 1.8.0, applying this official update is the recommended remediation. No other mitigation or temporary workaround is indicated in the available data.
Description
SQLBot versions prior to 1.8.0 contain an authorization bypass vulnerability classified as CWE-639 (Authorization Bypass Through User-Controlled Key). This vulnerability affects the /api/v1/datasource/exportDsSchema and /api/v1/datasource/uploadDsSchema endpoints, allowing an attacker with limited privileges to access and modify database schemas and data sources belonging to other tenants or workspaces. The issue is fixed in version 1.8.0. The CVSS 4.0 base score is 8.6, indicating a high severity vulnerability.