Skip to main content
VulnerabilityPublished Updated

CVE-2026-42530: F5 NGINX Open Source · Use After Free

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 1.31.2 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.4% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.31.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade F5 NGINX Open Source to 1.31.2.

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.31.0 <1.31.2
Fixed in
  • 1.31.2

AI-suggested

The Red Hat advisory references this CVE but does not explicitly state that a patch or official fix is available. Until then, consider disabling the HTTP/3 QUIC module if feasible to mitigate exposure to this vulnerability.

Description

CVE-2026-42530 is a high-severity use-after-free vulnerability in the ngx_http_v3_module of NGINX Open Source version 1.31.0. When configured with the HTTP/3 QUIC module, a remote unauthenticated attacker can send a specially crafted HTTP/3 session to trigger a use-after-free condition, potentially causing the NGINX worker process to restart. On systems without Address Space Layout Randomization (ASLR) or where ASLR can be bypassed, this vulnerability may allow remote code execution. This vulnerability affects NGINX Open Source version 1.31.0. Red Hat has published an advisory but does not explicitly state a patch or fix for this specific vulnerability in their Hardened Images RPMs update.

References

Community reviews

Loading reviews…