Skip to main content
VulnerabilityPublished

CVE-2026-42551: flightphp core · Interpretation Conflict

Affects flightphp coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.18.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.18.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade core and flightphp/core to 3.18.1.

Affected software

ProductAffectedFixed in
flightphpcoreAffected
  • <3.18.1
Fixed in
  • 3.18.1
GitHubflightphp/corepkg:github/flightphp/coreOther threatsAffected
  • <3.18.1
Fixed in
  • 3.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade FlightPHP to version 3.18.1 or later, where this vulnerability is fixed. Since the vendor advisory confirms the fix in 3.18.1, applying this official patch is the recommended remediation. No alternative mitigations or temporary fixes are indicated in the available data.

Description

FlightPHP versions prior to 3.18.1 contain a vulnerability where the Request::getMethod() function unconditionally trusts the X-HTTP-Method-Override header and the $_REQUEST['_method'] parameter for all HTTP verbs, including safe ones like GET. This allows an attacker to change the HTTP method of a request silently, potentially turning a GET request into a DELETE or PUT. This behavior can lead to Cross-Site Request Forgery (CSRF) escalation against destructive endpoints, bypass middleware protections based on HTTP verbs, and cause cache poisoning between CDN and origin. The issue is fixed in version 3.18.1.

References

Community reviews

Loading reviews…