CVE-2026-42604: actualbudget actual · Incorrect Authorization
Affects actualbudget actualSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 26.5.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.5.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 12 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade actualbudget actual to 26.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| actualbudgetactual | Affected
| Fixed in
|
GitHubactualbudget/actualpkg:github/actualbudget/actualOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Actual Budget sync-server version 26.5.0 or later, where this vulnerability is fixed. Until upgrading, restrict access to the POST /openid/config endpoint and implement external rate limiting and monitoring to reduce brute-force risk. Patch status is not explicitly confirmed in the vendor advisory, but version 26.5.0 is stated as the fix version.
Description
Actual is a local-first personal finance tool. The `POST /openid/config` endpoint in Actual Budget's sync-server versions <= 26.4.0 exposes the full OpenID Connect configuration—including the OAuth2 `client_secret`—to any caller who knows the bootstrap password. The endpoint also lacks authentication and rate limiting, making the bootstrap password brute-forceable. Version 26.5.0 fixes the issue.