Skip to main content
VulnerabilityPublished Updated

CVE-2026-42789: Erlang OTP · Improper Certificate Validation

Affects Erlang OTPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.0 High : upgrade to 27.3.4.19 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 27.3.4.19, 1.17.1.7, 29.0.1 +3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade OTP to 27.3.4.19; OTP and public_key to 1.17.1.7; erlang/otp to 29.0.1, 28.5.0.1, 27.3.4.12 or 26.2.5.21.

Affected software

ProductAffectedFixed in
ErlangOTPAffected
  • >=17.0 <27.3.4.19
Fixed in
  • 27.3.4.19
ErlangOTPAffected
  • >=0.22 <1.17.1.7
Fixed in
  • 1.17.1.7
ErlangOTPAffected
  • ≥ 84adefa331c4159d432d22840663c38f155cd4c1, < 0a05b7ca33fb0b3f0a6cb9ae34252bb3a74032b8
Fixed in–
GitHuberlang/otppkg:github/erlang/otpOther threatsAffected
  • <26.2.5.21
  • <27.3.4.12
  • <28.5.0.1
  • <29.0.1
Fixed in
  • 26.2.5.21
  • 27.3.4.12
  • 28.5.0.1
  • 29.0.1
GitHubpublic_keypkg:github/public_keyOther threatsAffected
  • >=0.22 <1.17.1.7
Fixed in
  • 1.17.1.7

CPE configurations (1)

  • cpe:2.3:a:erlang:erlang\/otp:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected systems. Red Hat has released updated Erlang packages addressing this vulnerability, particularly for Red Hat OpenStack Services on OpenShift 18.0. Users should update to the fixed versions as detailed in the Red Hat advisory (RHSA-2026:39809). No effective mitigations other than applying the official patch are currently available or meet Red Hat's criteria for widespread deployment and stability.

Description

Improper Following of a Certificate's Chain of Trust vulnerability in Erlang OTP public_key (pubkey_cert module) allows a non-CA certificate to be accepted as an intermediate issuer, enabling certificate chain forgery. In lib/public_key/src/pubkey_cert.erl, pubkey_cert:validate_extensions/7 contains two flaws that together allow a certificate with basicConstraints cA:false and no keyUsage extension to be used as an intermediate issuer in a chain passed to public_key:pkix_path_validation/3: the cA:false clause recurses into the remaining extensions without rejecting the certificate when it is in issuer position, and the keyUsage check only fires when the extension is present, so a certificate lacking keyUsage entirely bypasses the keyCertSign enforcement. Any party holding an end-entity certificate with basicConstraints cA:false and no keyUsage extension, issued by any CA in the victim's trust store, can use that certificate's private key to sign forged leaf certificates for arbitrary identities. public_key:pkix_path_validation/3 accepts the resulting chain, and by extension every TLS or mTLS endpoint built on the OTP ssl application that relies on the default verifier is affected, including server identity verification on the client side and client certificate verification on mTLS servers. This issue affects OTP from OTP 17.0 before OTP 27.3.4.19, OTP 28.5.0.8, and OTP 29.1.2, corresponding to public_key from 0.22 before 1.17.1.7, 1.20.3.6, and 1.21.8. Whether OTP before OTP 17.0, corresponding to public_key before 0.22, is affected is unknown.

References

Community reviews

Loading reviews…