CVE-2026-43569: OpenClaw · Untrusted Functionality Inclusion
Affects OpenClawSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 2026.4.9 soon.
Data as of 27 Oct 2026, 02:03 UTC
- Patch
- Available – fixed in 2026.4.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade OpenClaw to 2026.4.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenClaw OpenClaw | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should avoid non-interactive onboarding processes that could enable untrusted plugins or implement manual verification of enabled plugins during onboarding.
Description
OpenClaw before version 2026.4.9 has an authentication bypass vulnerability (CVE-2026-43569) that allows untrusted workspace plugins to be automatically enabled during non-interactive onboarding when provider authentication choices are shadowed. This enables attackers to craft malicious plugins that are selected and enabled without explicit user consent, potentially compromising authentication integrity.
References
- github.com/openclaw/openclaw/security/advisories/GHSA-939r-rj45-g2rj (opens in a new tab)
- github.com/openclaw/openclaw/commit/2d97eae53e212ae26f3aebcd6a50ffc6877f770d (opens in a new tab)
- vulncheck.com/advisories/openclaw-untrusted-provider-plugin-auto-enablement-via-workspace-provider-auth (opens in a new tab)