Skip to main content
VulnerabilityPublished Updated

CVE-2026-4371: Mozilla Thunderbird · CWE-126

Affects Mozilla ThunderbirdSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.4 High · patch available : patch Mozilla Thunderbird soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Mozilla ThunderbirdAffected
  • <140.9
Fixed in
  • 140.9

AI-suggested

A fix is available and users should upgrade to Thunderbird version 140.9 or later, including version 149 where the vulnerability is also fixed. Mozilla's official advisories confirm these versions contain the patch. Since this is a client-side vulnerability triggered by malicious mail servers, upgrading Thunderbird to a fixed version is the primary mitigation. No additional vendor-recommended mitigations or workarounds are indicated. There are no known exploits in the wild at this time.

Description

A malicious mail server could send malformed strings with negative lengths, causing the parser to read memory outside the buffer. If a mail server or connection to a mail server were compromised, an attacker could cause the parser to malfunction, potentially crashing Thunderbird or leaking sensitive data. This vulnerability was fixed in Thunderbird 149 and Thunderbird 140.9.

References

Community reviews

Loading reviews…