CVE-2026-43906: AcademySoftwareFoundation OpenImageIO · Heap-based Buffer Overflow
Affects AcademySoftwareFoundation OpenImageIOSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 3.1.13.0 or 3.0.18.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.13.0, 3.0.18.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade OpenImageIO to 3.1.13.0 or 3.0.18.0; academysoftwarefoundation/OpenImageIO to 3.0.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AcademySoftwareFoundationOpenImageIO | Affected
| Fixed in
|
| AcademySoftwareFoundationOpenImageIO | Affected
| Fixed in
|
GitHubacademysoftwarefoundation/OpenImageIOpkg:github/academysoftwarefoundation/OpenImageIOOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in OpenImageIO versions 3.0.18.0 and 3.1.13.0. Users should upgrade to these or later versions to remediate this vulnerability. No vendor advisory content contradicts this; therefore, upgrading is the recommended mitigation.
Description
A heap-based buffer overflow vulnerability exists in the HEIF decoder of AcademySoftwareFoundation's OpenImageIO prior to versions 3.0.18.0 and 3.1.13.0. This flaw allows out-of-bounds writes triggered by crafted images with subimage metadata mismatches, potentially causing memory corruption and enabling code execution. The vulnerability is addressed in OpenImageIO versions 3.0.