Skip to main content
VulnerabilityPublished Updated

CVE-2026-44016: docling · Code Injection

Affects doclingSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 2.91.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.91.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade docling to 2.91.0.

Affected software

ProductAffectedFixed in
docling-projectdoclingAffected
  • >=2.82.0 <2.91.0
Fixed in
  • 2.91.0

AI-suggested

A fix is available in docling version 2.91.0. Users should upgrade to version 2.91.0 or later to remediate this vulnerability. If upgrading is not immediately possible, avoid enabling the HTML backend rendering feature or processing untrusted HTML documents with this feature enabled. Consult the Red Hat advisory at https://access.redhat.com/security/cve/CVE-2026-44016 for additional guidance.

Description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. FIn versions >= 2.82.0, < 2.91.0, if the HTML backend was explicitly configured for rendering (rendering option by default deactivated), then the Playwright-based rendering feature could allow JavaScript execution and unrestricted network access when processing untrusted HTML documents. An attacker could craft malicious HTML that executes arbitrary JavaScript in the rendering context or makes unauthorized network requests to internal services, potentially leading to SSRF attacks, data exfiltration, or remote code execution in the rendering environment. This vulnerability is fixed in 2.91.0.

References

Community reviews

Loading reviews…